Error #309

qMp kalimotxo compilation fails due to missing radvd dependencies (libdaemon)

Added by Roger Pueyo Centelles over 6 years ago. Updated over 6 years ago.

Target version:
Start date:
Due date:
% Done:


Spent time:


Hi there,

qMp (kalimotxo branch) compilation fails when building radvd. It seems that radvd depends on package libdaemon, which is no longer available. See the compilation log:

. /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/include/; gzip -dc /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/dl/radvd-1.9.1.tar.gz | /bin/tar -C /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc- -xf - 

Applying ./patches/100-silent-netlink-config-reload.patch using plaintext: 
patching file netlink.c
patching file radvd.c
patching file radvd.h
patching file send.c
touch /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc-
(cd /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc-; if [ -x ./configure ]; then /usr/bin/find /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc- -name config.guess | xargs -r chmod u+w; /usr/bin/find /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc- -name config.guess | xargs -r -n1 cp /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/scripts/config.guess; /usr/bin/find /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc- -name config.sub | xargs -r chmod u+w; /usr/bin/find /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/build_dir/target-mips_34kc_uClibc- -name config.sub | xargs -r -n1 cp /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/scripts/config.sub; AR=mips-openwrt-linux-uclibc-ar AS="mips-openwrt-linux-uclibc-gcc -c -Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="mips-openwrt-linux-uclibc-gcc" GCC="mips-openwrt-linux-uclibc-gcc" CXX="mips-openwrt-linux-uclibc-g++" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size CFLAGS="-Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16 -minterlink-mips16 " CXXFLAGS="-Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16 -minterlink-mips16 " CPPFLAGS="-I/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/target-mips_34kc_uClibc- -I/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/target-mips_34kc_uClibc- -I/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc- -I/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc- " LDFLAGS="-L/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/target-mips_34kc_uClibc- -L/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/target-mips_34kc_uClibc- -L/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc- -L/home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc- "   ./configure --target=mips-openwrt-linux --host=mips-openwrt-linux --build=x86_64-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib --sysconfdir=/etc --datadir=/usr/share --localstatedir=/var --mandir=/usr/man --infodir=/usr/info --disable-nls   --with-configfile=/etc/radvd.conf --with-logfile=/var/log/radvd.log --with-pidfile=/var/run/ ; fi; )
configure: WARNING: unrecognized options: --disable-nls
configure: loading site script /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/include/site/mips-openwrt-linux-uclibc
checking build system type... x86_64-pc-linux-gnu
checking host system type... mips-openwrt-linux-gnu
checking target system type... mips-openwrt-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for mips-openwrt-linux-strip... mips-openwrt-linux-uclibc-strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking architecture... linux
checking for mips-openwrt-linux-gcc... mips-openwrt-linux-uclibc-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... yes
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether mips-openwrt-linux-uclibc-gcc accepts -g... yes
checking for mips-openwrt-linux-uclibc-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of mips-openwrt-linux-uclibc-gcc... gcc3
checking netlink... yes
checking for rm... /bin/rm
checking for sed... /home/compilator/qMp/qmpfw-WR703N-kx/build/openwrt/staging_dir/host/bin/sed
checking for ln... /bin/ln
checking for bison... bison -y
checking for flex... flex
checking lex output file root... lex.yy
checking lex library... none needed
checking whether yytext is a pointer... no
checking for tar... /bin/tar
checking for gzip... /bin/gzip
checking where to put logfile... /var/log/radvd.log
checking where to put pidfile... /var/run/
checking where to find configfile... /etc/radvd.conf
checking which syslog facility to use... LOG_DAEMON
checking for inet_ntop in -lc... yes
checking pkg-config is at least version 0.9.0... yes
checking for DAEMON... no
configure: error: Package requirements (libdaemon) were not met:

No package 'libdaemon' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Time to get rid of radvd?


#1 Updated by Roger Pueyo Centelles over 6 years ago

  • Status changed from Nou to Tancat

Just waited for it to get solved automagically.

#2 Updated by Agustí Moll Garcia over 6 years ago

  • Status changed from Tancat to En progrés

Waiting to be determined by including the github repository, I have done

diff --git a/Makefile b/Makefile
index bc158af..9455508 100644
--- a/Makefile
+++ b/Makefile
@ -202,6 +202,7 @ all: build

$(OWRT_PKG_SCM) $(BUILD_DIR)/packages
+ cd $(BUILD_DIR)/packages && git reset --hard
touch $

#3 Updated by Pau Escrich over 6 years ago

radvd must be removed and we should use the new standard tools for IPv6 autoconfiguration provided by OpenWRT (configuration from /etc/config/dhcp)

#4 Updated by Roger Pueyo Centelles over 6 years ago

  • Status changed from En progrés to Tancat
  • Assignee changed from Pau Escrich to Roger Pueyo Centelles
  • % Done changed from 0 to 100

The issue has been solved. qMp/qMpFW have been patched to use the old OpenWrt packages repository. This is a temporary patch, while radvd is in the old packages repository. In the future, only the new repository at GitHub should be used.

See and .

Also available in: Atom PDF