Project

General

Profile

Error #265

TPlink WDR3600/4300 hooks sets the switch configuration without support to connect in mesh

Added by Jorge L. Florit about 7 years ago. Updated about 2 years ago.

Status:
Tancat
Priority:
Alta
Assignee:
-
Category:
Init scripts
Target version:
-
Start date:
08/06/2013
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:

Description

The configuration of switch that should look like this [1], with a fresh instalation of testing branch image the hooks scripts set the node with this configuration (that doesn't allow to connect in Mesh at anyport):

~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '0t 1'

config interface 'wan_e0_2'
option ifname 'eth0.2'
option proto 'dhcp'
option metric '2048'

config interface 'lan'
option type 'bridge'
option auto '1'
option proto 'static'
option ipaddr '172.30.22.1'
option netmask '255.255.0.0'
option dns '141.1.1.1 85.126.4.170 202.83.95.227'
list ifname 'eth0.1'
option ip6addr 'fd00:1714:1714:6aa2::1/64'

config interface 'mesh_w0_11'
option ifname '@mesh_w0.11'
option proto 'static'
option ip6addr 'FD01:0:0:6470:267:6AA2:0:11/128'

config interface 'mesh_w0_12'
option ifname '@mesh_w0.12'
option proto 'static'
option ip6addr 'FD02:0:0:6470:267:6AA2:0:12/128'

config interface 'mesh_w0'
option proto 'static'
option ipaddr '169.254.164.1'
option netmask '255.255.255.248'

config interface 'mesh_e0_12_11'
option ifname '@mesh_e0_12.11'
option proto 'static'
option ip6addr 'FD01:0:0:6470:267:6AA2:0:21/128'

config interface 'mesh_e0_12'
option proto 'static'
option ipaddr '169.254.255.1'
option netmask '255.255.255.248'
option ifname 'eth0.12'

[1] http://qmp.cat/projects/qmp/wiki/WDR3600_WDR4300

History

#1 Updated by Roger Pueyo Centelles about 2 years ago

  • Status changed from Nou to Tancat
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

Meshing via 802.1ad avoids this issue.

Also available in: Atom PDF