Project

General

Profile

Error #489

Duplicate bridge br-lan in routers with switched Ethernet interface

Added by Roger Pueyo Centelles about 1 month ago. Updated about 1 month ago.

Status:
Tancat
Priority:
Normal
Category:
Network
Target version:
Start date:
09/18/2021
Due date:
% Done:

100%

Estimated time:
12.00 h

Description

E.g.: Phicomm K2P/KE2P:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option type 'bridge'
        option auto '1'
        option proto 'static'
        option ipaddr '172.30.22.1'
        option netmask '255.255.0.0'
        option dns '208.67.222.222 77.109.148.136 109.69.8.34'
        option ip6addr 'fd00:1714:1714:93ad::1/64'

Associated revisions

Revision 87c3f922 (diff)
Added by Roger Pueyo Centelles about 1 month ago

[qmp-system] Migrate to new UCI network model (II)

Add the qmp_uci_get_raw_item_space_filter_by_name() function to
complete the qmp_uci_get_item_by_unnamed_section_type_and_name()
function, which would otherwise incorrectly return the items for
all the unnamed sections of a given class, instead of just the one
filtered by its "name" property value.

Fixes #489.

Signed-off-by: Roger Pueyo Centelles <>

Revision 38b2f82a (diff)
Added by Roger Pueyo Centelles about 1 month ago

[qmp-system] Migrate to new UCI network model (III)

On first boot call qmp_configure_smart_network() with force parameter,
and add to phydevs OpenWrt's default LAN and WAN interfaces, which may
not be detected as physical interfaces in some corner cases.

Fixes #489.

Signed-off-by: Roger Pueyo Centelles <>

Revision 219af226 (diff)
Added by Roger Pueyo Centelles about 1 month ago

[qmp-system] Migrate to new UCI network model (IV)

This commit applies to wireless interfaces.

Fixes #489.

Signed-off-by: Roger Pueyo Centelles <>

History

#1 Updated by Roger Pueyo Centelles about 1 month ago

Works:

config interface 'lan'
        option type 'bridge'
        option auto '1'
        option proto 'static'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option ipaddr '172.30.22.1'
        option netmask '255.255.0.0'
        option dns '208.67.222.222 77.109.148.136 109.69.8.34'
        option ip6addr 'fd00:1714:1714:93ad::1/64'

#2 Updated by Roger Pueyo Centelles about 1 month ago

/etc/config/network migration with LuCi.

Before:

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
    option ifname 'lo'

config globals 'globals'
    option packet_steering '1'
    option ula_prefix 'fdde:1d0c:454f::/48'

config interface 'lan'
        option type 'bridge'
        option auto '1'
        option proto 'static'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option ipaddr '172.30.22.1'
        option netmask '255.255.0.0'
        option dns '208.67.222.222 77.109.148.136 109.69.8.34'
        option ip6addr 'fd00:1714:1714:93ad::1/64'

config device 'wlan0_12'
    option type '8021q'
    option name 'wlan0_12'
    option ifname '@mesh_w0'
    option vid '12'
    option proto 'static'
    option ip6addr 'FD02:0:0:FC7C:2B4:3444:0:612/128'

config interface 'wlan0_12_q'
    option ifname 'wlan0_12'
    option auto '1'

config interface 'mesh_w0'
    option proto 'static'
    option ipaddr '169.254.69.1'
    option netmask '255.255.255.248'

config device 'wlan1_12'
    option type '8021q'
    option name 'wlan1_12'
    option ifname '@mesh_w1'
    option vid '12'
    option proto 'static'
    option ip6addr 'FD02:0:0:FC7C:2B4:3444:0:712/128'

config interface 'wlan1_12_q'
    option ifname 'wlan1_12'
    option auto '1'

config interface 'mesh_w1'
    option proto 'static'
    option ipaddr '169.254.69.1'
    option netmask '255.255.255.248'

After:

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
    option ifname 'lo'

config globals 'globals'
    option packet_steering '1'
    option ula_prefix 'fdde:1d0c:454f::/48'

config interface 'lan'
    option type 'bridge'
    option auto '1'
    option proto 'static'
    list ports 'lan1'
    list ports 'lan2'
    list ports 'lan3'
    list ports 'lan4'
    option ipaddr '172.30.22.1'
    option netmask '255.255.0.0'
    option dns '208.67.222.222 77.109.148.136 109.69.8.34'
    option ip6addr 'fd00:1714:1714:93ad::1/64'

config device 'wlan0_12'
    option type '8021q'
    option name 'wlan0_12'
    option ifname '@mesh_w0'
    option vid '12'
    option proto 'static'
    option ip6addr 'FD02:0:0:FC7C:2B4:3444:0:612/128'

config interface 'wlan0_12_q'
    option auto '1'
    option device 'wlan0_12'

config interface 'mesh_w0'
    option proto 'static'
    option ipaddr '169.254.69.1'
    option netmask '255.255.255.248'

config device 'wlan1_12'
    option type '8021q'
    option name 'wlan1_12'
    option ifname '@mesh_w1'
    option vid '12'
    option proto 'static'
    option ip6addr 'FD02:0:0:FC7C:2B4:3444:0:712/128'

config interface 'wlan1_12_q'
    option auto '1'
    option device 'wlan1_12'

config interface 'mesh_w1'
    option proto 'static'
    option ipaddr '169.254.69.1'
    option netmask '255.255.255.248'

#3 Updated by Roger Pueyo Centelles about 1 month ago

  • Subject changed from Duplicate bridge br-lan in routers with DSA driver to Duplicate bridge br-lan in routers with switched Ethernet interface

EdgeSwitch 8XP:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 5 6 7 8t'

config interface 'lan'
        option type 'bridge'
        option auto '1'
        option proto 'static'
        option ipaddr '172.30.22.1'
        option netmask '255.255.0.0'
        option dns '208.67.222.222 77.109.148.136 109.69.8.34'
        option ip6addr 'fd00:1714:1714:43d7::1/64'

#4 Updated by Roger Pueyo Centelles about 1 month ago

892fc7caa9eee9f5ef9e172677f871c02841bae8

#5 Updated by Roger Pueyo Centelles about 1 month ago

  • Status changed from Nou to Tancat
  • % Done changed from 0 to 100

Aplicat en el conjunt de canvis 87c3f92236faa93bbef77959dd5488831592d1f1.

Also available in: Atom PDF