Project

General

Profile

Error #462

During first boot's autoconf, both radios in 5 and 2.4 GHz are set as "802.11s + AP (LAN)" with wrong network in /etc/config/wireless

Added by Roger Pueyo Centelles about 1 year ago. Updated about 1 year ago.

Status:
Tancat
Priority:
Alta
Category:
Wireless
Target version:
Start date:
09/17/2018
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:

Description

For instance:

config wifi-iface 'wlan0'
    option device 'radio0'
    option mode 'mesh'
    option mesh_id 'qMp'
    option ifname 'wlan0'
    option mesh_fwding '0'
    option network 'lan' <=== WRONG!

config wifi-iface 'wlan0ap'
    option device 'radio0'
    option mode 'ap'
    option ssid 'qMp-AP'
    option network 'lan'
    option encryption 'none'
    option ifname 'wlan0ap'

Associated revisions

Revision 3dac3ef7 (diff)
Added by Roger Pueyo Centelles about 1 year ago

[qmp-system] Fix wrong addition of wireless interfaces to br-lan

Fixes #462

Signed-off-by: Roger Pueyo Centelles <>

History

#1 Updated by Roger Pueyo Centelles about 1 year ago

  • % Done changed from 0 to 10

#2 Updated by Roger Pueyo Centelles about 1 year ago

  • % Done changed from 10 to 20

This won't happen on a device with two dual-band radios (they get proper [auto]configuration) but on a device with 2 single-band devices on different frequencies.

#3 Updated by Roger Pueyo Centelles about 1 year ago

  • % Done changed from 20 to 30

"qmpcontrol configure_wifi" does it right, "qmpcontrol configure_network", which is run later, breaks it.

#4 Updated by Roger Pueyo Centelles about 1 year ago

  • % Done changed from 30 to 100

#5 Updated by Roger Pueyo Centelles about 1 year ago

  • Status changed from Nou to Resolt

#6 Updated by Roger Pueyo Centelles about 1 year ago

  • Status changed from Resolt to Tancat

Also available in: Atom PDF