Project

General

Profile

Error #481

LAN bridge consistently gets 169.254.185.1 address during qmp_autoconf

Added by Roger Pueyo Centelles 4 months ago. Updated about 1 month ago.

Status:
Tancat
Priority:
Urgent
Category:
Network
Target version:
Start date:
04/29/2020
Due date:
% Done:

100%

Estimated time:
10.00 h
Spent time:

Description

Instead of 172.30.22.1, it gets 169.254.185.1.

Associated revisions

Revision b45499e1 (diff)
Added by Roger Pueyo Centelles about 1 month ago

[qmp-system] Fix viface for 2.4 GHz 80211s_aplan radios

On first boot, routers with a single 2.4 GHz radio had it auto-
configured as 80211s_aplan, with interface wlan0 as 80211s and
wlan0ap as AP. However, the wlan0 interface was wrongly considered
as being inside the virtual interface (viface) "lan" instead of
"mesh_w0". This was a corner case in the qmp_get_virtual_iface()
function, which ultimately made rescue_ip 169.254.x.y to be
incorrectly assigned to "br-lan" instead of "mesh_w0".

Fixes #481.

Signed-off-by: Roger Pueyo Centelles <>

Revision 03cabbb7 (diff)
Added by Roger Pueyo Centelles about 1 month ago

[qmp-system] Get wifi devices for qmp_get_wifi_devices() also from ubus.

Continues 7c75474ed496fd5e6bffa9c9823b8d825490cf50,
cb7fd04423ce05fa64b96efb6667421b33bf100c,
6c5212f16880ac84359532fdebd518b26cede3e3 and
b45499e1dc4ef962120a9f5970be99a7d19f8cef.

Fixes #481.

Signed-off-by: Roger Pueyo Centelles <>

Revision 1ff5c11a (diff)
Added by Roger Pueyo Centelles about 1 month ago

[qmp-system] Get wifi devices for qmp_get_wifi_devices() also from ubus.

Continues 7c75474ed496fd5e6bffa9c9823b8d825490cf50,
cb7fd04423ce05fa64b96efb6667421b33bf100c,
6c5212f16880ac84359532fdebd518b26cede3e3 and
b45499e1dc4ef962120a9f5970be99a7d19f8cef.

Fixes #481.

Signed-off-by: Roger Pueyo Centelles <>

History

#1 Updated by Roger Pueyo Centelles 3 months ago

  • Category set to Network
  • Target version set to 5.0.0 "Leverage"
  • Estimated time set to 10.00 h

Observed on a single-2.4 GHz radio device with 2 switched Ethernet ports (eth0.1, eth0.2).

AP radio is correct, but 802.11 radio is in the wrong network:

config wifi-iface 'wlan0'
option device 'radio0'
option mode 'mesh'
option mesh_id 'qMp'
option ifname 'wlan0'
option mesh_fwding '0'
option encryption 'none'
option network 'lan'

config wifi-iface 'wlan0ap'
option device 'radio0'
option mode 'ap'
option ssid 'qMp-AP'
option network 'lan'
option encryption 'none'
option ifname 'wlan0ap'

#2 Updated by Roger Pueyo Centelles 3 months ago

  • % Done changed from 0 to 20

After this:
log "[Initial qMp system configuration]"
qmp_configure_initial

Config is OK.

After this:
log "[Full qMp system configuration]"
qmp_configure

Config is wrong.

#3 Updated by Roger Pueyo Centelles about 1 month ago

  • Status changed from Nou to Tancat
  • % Done changed from 20 to 100

Aplicat en el conjunt de canvis b45499e1dc4ef962120a9f5970be99a7d19f8cef.

#5 Updated by Roger Pueyo Centelles about 1 month ago

The information source for qmp_get_wifi_devices is sometimes slow to report the wireless devices information:

root@qMp-b38c:~# wifi; ubus call network.wireless status | jsonfilter -e '@.*.interfaces.*.section' | sort; echo "#########"; qmp_get_wifi_devices
wlan0
wlan1
wlan1ap
#########
wlan0 wlan1 wlan1ap
root@qMp-b38c:~# wifi; ubus call network.wireless status | jsonfilter -e '@.*.interfaces.*.section' | sort; echo "#########"; qmp_get_wifi_devices
wlan0
wlan1
wlan1ap
#########
wlan1 wlan1ap #<== wlan0 missing!

while ubus seems to report it always on time. Therefore, ubus should [also] be used as the wifi devices list source in qmp_get_wifi devices. Finally, in 03cabbb736658bd501ed7e0a28694f142f2c752a .

Also available in: Atom PDF